Can-Am Commander Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
The display will show H, will not show L. will not go over 20 mph. This SBS is new to me, it's a 2016 commander 800R. Looks to be ridden hard. The engine runs well. I did replace the primary clutch, secondary clutch, and belt. This was a nightmare. Thank you, Dremel! Nothing really changed in how fast this machine will go. Any advice would be greatly appreciated.
Wood Cone Office supplies Gas Art
 

· Administrator
Joined
·
27,847 Posts
I assume the seat belt switch is working properly. When you turn the machine on is it scrolling performance key across the dash? If not you may have a key programmed as the safety key.
 

· Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Yes it show "Performance Key" on display. First test run after both clutches and belt replacement got up to 40 mph in H and smoked the new can am belt. L tops out at 20 mph. Explain the seat belt switch. I just kept the seat belt latched behind me. when test driving.
 

· Administrator
Joined
·
27,847 Posts
If it got up to 40 seat belt switch is working . But if you got to 40 and smoked the belt something isn’t right either in the primary or secondary. When it hits 20 in low what are the rpm’s showing?
 

· Registered
Joined
·
272 Posts
Does sound it's not the problem you are having, but if the seat belt is not connected it will display a seat belt message on the display and speed will be limited to around 10mph I believe.
 
1 - 5 of 5 Posts
Top