Can-Am Commander Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Bringing mine to the closest dealer, who admits they've never worked on this problem before but were willing to hook up the BUDS and give it a try. I'd like to have another dealer that has successfully done it on standby so we can give them a call if necessary.
 

·
Registered
Joined
·
884 Posts
I've been searching the service manual, and can't find pertinent info. I wonder if BUDS would allow you to delete/ignore the suspension control module, or maybe change the vehicle model (to a non-limited model). Maybe Ace can look at the program.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3
This things a lot smarter than I am, that's for sure. I aired the shocks up, shut off machine, removed relay and it still knew there was a problem. Even with the relay removed the display on the dash scrolled 'suspension pump overheat', the compressor wasn't even running. The system worked fine until it sucked in all that lake water, so I'm leaning toward a mechanical problem versus an electrical or software issue.
 

·
Super Moderator
Joined
·
25,539 Posts
You can turn off the air ride with buds. And it's the only way to keep the engine light from coming on and putting the machine in limp mode.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #5
Well, surprise surprise, my dealer is one of the ignorant ones who couldn't figure it out. They managed to remove the relay, just like I tried at home, and charged me $250. Engine light comes on but he assured me that the machine won't go into limp mode. Is he right?
 

·
Super Moderator
Joined
·
25,539 Posts
If they didn't do anything then they shouldn't have charged you. I had my buds system for less than a hr and found it with no outside help. Its in same section with the speed limiter and the dps options actually on same screen .
 
1 - 7 of 7 Posts
Top