Can-Am Commander Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Posted this in the Electric forum, didn’t know there was a Battery powered Commander?? Anyway after three or four miles if I stop and shut the motor off then try to re-start the starter drags really bad. But after it cools off it starts just fine. Time for a new starter? Or am I missing something??
 

·
Registered
Joined
·
1,453 Posts
I have the same issue although very intermittently. Since it seems to happen only when hot I figure its the starter although I was just riding for 2 weeks in 95+ temps. and I didn't seem to notice it this year.

Steve
 

·
Registered
Joined
·
5 Posts
Stator problems

Stator keeps going out. Found radiator fluid in the oil. I know" blown head gasket" but would yhat cause stator to go out? Also sence i changed the stator i noticed a rattle sound from it. Is this normal and just dont gere it because its under the seat?
 

·
Registered
Joined
·
5 Posts
Figured out the dragging starter. It was a bad ignition switch. Common prob. They get wet easy when washing n riding
 

·
Registered
Joined
·
2 Posts
I'm having the same issue and it was not the starter (I had that replaced). Did replacing the ignition switch solve your problem?
 

·
Registered
Joined
·
17 Posts
Discussion Starter #12
One year update, I replaced the battery with a Odyssey PC925L. Used a EMP battery box conversion, and I have never had the problem again. I still use a battery tender when it is not in use.
 
1 - 12 of 12 Posts
Top