Can-Am Commander Forum banner

1 - 20 of 89 Posts

·
Registered
Joined
·
103 Posts
Discussion Starter #1
Backed my 2012 out if garage today just put new battery in it today. It was outside idling and went to go and went 10 ft and died. Just cranks over. I dumped a small amout if gas in it and it ran till it burnt through it. So questions are, will the fuel pump just die. ? And is it in the gas tank? Any cheaper ones available?

Sent from my LM-Q710.FG using Tapatalk
 

·
Registered
Joined
·
7,820 Posts
Uhhh, add more gas? If you add fuel and it starts, its not your fuel pump. With that said, if the fuel pump is bad (barring an electrical short/fuse/connection) they will usually start, run, and drive until the pump gets hot.
 

·
Super Moderator
Joined
·
23,509 Posts
Yes they are electric so they can go at anytime . Check all fuses . Listen to see if you can hear it run when you first turn key on.
these can be bought or ordered from any auto parts stores.
 

·
Registered
Joined
·
103 Posts
Discussion Starter #4
Thx guys. Hopefully get a chance to look at it this week.

Sent from my LM-Q710.FG using Tapatalk
 

·
Registered
Joined
·
103 Posts
Discussion Starter #8
Thanks Acefire. Ill keep origanal 1 i got.

Sent from my LM-Q710.FG using Tapatalk
 

·
Registered
Joined
·
103 Posts
Discussion Starter #9
Well put new pump on and nothing. Checked wiring. Didnt take it out of protective sheild though. Put a meter to it and turned it on. Got 4.59 volts at plug black on black wire and red on 2nd one from black.


Sent from my LM-Q710.FG using Tapatalk
 

·
Registered
Joined
·
103 Posts
Discussion Starter #10 (Edited)
Fuel gauge is working. Doest the whole unit have to be in the tank to ground? I just tried it not in the tank.
 

·
Registered
Joined
·
513 Posts
Wrong wires. Pump supply wires are blk/blu and blu/gry. Numbers 3 and 4, molded into that plug housing. Remember you should only get voltage for a few seconds after turning on the key. fuel pump wires.jpg
 

·
Registered
Joined
·
103 Posts
Discussion Starter #15
Yes over half a tank. Wiring is not my strong point. thanks guys ill try again this weekend. Cannedham that wiring diagram may as well be in french! But i dont see those colors in that pic?

Sent from my LM-Q710.FG using Tapatalk
 

·
Registered
Joined
·
103 Posts
Discussion Starter #16
Is there a relay for fuel pump somewhere? I see 1 for injectors

Sent from my LM-Q710.FG using Tapatalk
 

·
Super Moderator
Joined
·
23,509 Posts
Pretty sure it runs off of the R1 relay. But not 100% positives . The cannedham is much better at the wiring blueprints.
 

·
Registered
Joined
·
103 Posts
Discussion Starter #20
Ok thx guys. Tail lights work, bummer. Found the wores that are supposed to be power to fuel pump. I didn't see the stripes on them. Eliminates thoses. So looking for the ground wire. If not i guess ill have to take the wiring out of the corrugated plastic cover and inspect all of it?

Sent from my LM-Q710.FG using Tapatalk
 
1 - 20 of 89 Posts
Top