Can-Am Commander Forum banner
1 - 20 of 81 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter · #1 ·
I bought a new 2014 rackzilla quick steer ratio rack. My machine is a 2013 with dps which wicked built does not offer. I read a thread on here saying that the 2014 will work. I also got the update kit from can am that had a new coupler and dps brackets. Didnt use the coupler but changed brackets. The problem im having is the zilla coupler has play on the dps side. And is tight on the rack. Everything is tight and appears to be lined up! Anybody have any insight? Tired of working on this damn thing. Was tight then loosened up on second ride.
 

·
Registered
Joined
·
8,116 Posts
Following this for sure! I have a 2013 X that hasn’t moved from the garage since last year after putting the rackzilla in. I am by no means blaming rackzilla but am uncomfortable driving it. Any help would be awesome!!!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
8,116 Posts
OP. You say rackzilla does not offer a rack for a 2013. That is interesting. When I ordered the 2014 rack from them, the reason was because I thought I had a 2014 rack in my machine that I bought new new in 2013 and is titled the same. The reason I thought this is because when I ordered turnkey tie rods for a ‘13 they wouldn’t fit. (Turnkey sent me clevis’ for a ‘14) (Thanks Turnkey!)


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
5,852 Posts
Following this for sure! I have a 2013 X that hasn’t moved from the garage since last year after putting the rackzilla in. I am by no means blaming rackzilla but am uncomfortable driving it. Any help would be awesome!!!


Sent from my iPhone using Tapatalk
Strange but in sept of 2014 I purchased and installed a Rackzilla for my 2013 1000"X" been working great since, but did change out the OEM coupler with a new style OEM Warranty coupler, went in with no issues except it being a Royal PITA to do.
 

·
Registered
Joined
·
8,116 Posts
Following this for sure! I have a 2013 X that hasn’t moved from the garage since last year after putting the rackzilla in. I am by no means blaming rackzilla but am uncomfortable driving it. Any help would be awesome!!!


Sent from my iPhone using Tapatalk
Strange but in sept of 2014 I purchased and installed a Rackzilla for my 2013 1000"X" been working great since, but did change out the OEM coupler with a new style OEM Warranty coupler, went in with no issues except it being a Royal PITA to


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
8,116 Posts
My coupler was replaced under warranty as well. I set it aside when I went to install the rackzilla rack.....


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #7 ·
This racks pinion shaft is the same size as the dps shaft. The factory rack has smaller splines than the zilla rack. Kit came with a special coupler to accommodate. I only have play on the dps side. Either the couple has the wrong spine size or ots because the couple has about 3 spines missing where the clamp split is. Im assuming for a blind tooth that i dont have
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #9 ·
I dont know how to post pictures on here but the side with the split isnt even touching the dps shaft. It was good and tight. Got into a gulley and dps was working hard. Then i felt something loosen up. After making it back to the truck i noticed it had play
 

·
Registered
Joined
·
8,116 Posts
Did you also put the updated dps brackets on booger?


I did not put the additional spacers on that came with the rackzilla. I was told they were unnecessary. Mine go between the rack and where the rack mounts just so we are on the same page. Boog.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #12 ·
Boog these were for the dps unit its self. Bigger mounting brackets and some spacers that go between dps and brackets. Was in a kit brp gave me. Allows more adjustment for the dps. I used the wicked spacers and it bound every thing up. So i had to take it back apart take them out.
 

·
Registered
Joined
·
8,116 Posts
My rack came straight from rackzilla. The only spacers I have came with it and I was told by guys not to install. My steering still doesn’t work. I’m interested to hear what you find out.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #18 ·
Well i did some searching and it appears the the 2014 dps unit is different than the 2013. It looks like the shaft is bigger and there is a groove cut for a bolt like the rack has. Which makes sense because the 2013 coupler was pressed on and the 2014 coupler isn't. Im gonna call wicked built tomorrow and see what we can do. Other wise probably going to have to get one machined somehow.
 

·
Administrator
Joined
·
26,912 Posts
Ok not reading through al this . You needed the recall coupler for the 13 model from the dealer . And a 11/13 !! Rackzilla has been making a 13 rack sense 2011. You can not use a 14 coupler without modifying it to fit the 13 dps. The 14 dps is just a tough smaller and coupler will not tighten down on the 13 dps shaft .

8001610 this is the part number you need for the 13 model . If you got this part number then get the recall coupler from the dealer and no more issues .
 
1 - 20 of 81 Posts
Top