Can-Am Commander Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hey guys I’m new here but I have a 2015 commander 1000 XTP and its was running perfect after I just replaced the stator and changed water pump impellar out for a billet aluminum one. Put maybe 10 miles on it and it started having problems starting and dueling unless I give it gas. The check engine light came on and the P0106 code came on so I drove it home like 5 miles ran perfect the whole way home got home and idled for a few mn then died again and I can only get it to start if I give it gas then it will run and drive. I replaced the sensor on the intake and still nothing has changed. Changed the fuel filter and spark plugs with no change. I checked the fuel pump and I’m getting 50psi . It has almost 5000 miles on it if that helps. Any help would be appreciated because I’m about to take it to a dealer because I’m kinda stumped for once.
Wheel Sky Tire Car Vehicle
 

·
Registered
Joined
·
1,531 Posts
I would check the voltage at the battery while idling. I only suggest that because you just replaced the stator. You could also check voltage at the mapts according to manual. An intake leak is also a possibility.
Font Rectangle Line Material property Parallel
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
I would check the voltage at the battery while idling. I only suggest that because you just replaced the stator. You could also check voltage at the mapts according to manual. An intake leak is also a possibility.
View attachment 67611
I will do that as soon as I get over there. I haven’t checked the voltage at the battery since it started but I’ll see if I can get it to idle . Most of the time as when you hit the start button it starts then dies immediately and the throttle body slams shut. But sometimes it will idle for a few seconds
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
I would check the voltage at the battery while idling. I only suggest that because you just replaced the stator. You could also check voltage at the mapts according to manual. An intake leak is also a possibility.
View attachment 67611
Checked voltage to the battery and it was 14.5, everything checked out at the plug as well. Can’t seem to find any vacuume leaks either.. this one is irritating haha
 

·
Registered
Joined
·
1,531 Posts
Here's some info on checking the mapts wiring. I don't know if the ECM connector terminals are marked on the connector. Can Am suggests using a special adapter for wire probing, but it's pricey. Did you happen to adjust the valves recently? Another member here had similar idle issues after a routine valve adjustment. Re-adjustment solved the problem. I don't think his was throwing a mapts code, though.
Product Rectangle Font Parallel Pattern
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
Here's some info on checking the mapts wiring. I don't know if the ECM connector terminals are marked on the connector. Can Am suggests using a special adapter for wire probing, but it's pricey. Did you happen to adjust the valves recently? Another member here had similar idle issues after a routine valve adjustment. Re-adjustment solved the problem. I don't think his was throwing a mapts code, though.
View attachment 67613
I have not adjusted the valves, I was thinking about trying that tho but I guess that wouldn’t make it throw a code. I’ll try that next.
 

·
Registered
Joined
·
1,531 Posts
According to the service manual, intermittent or hard-to-diagnose faults may be caused by voltage issues, bad connections, grounds, etc. I would wonder about that since you must have had voltage issues which led to stator replacement. I noticed your fault codes displayed had 2 stars in front of them. That denotes that additional information for that code is available to the BUDS user, like fault count, running conditions when fault occurred, possible causes, and corrective actions. Did they delve in any further, or just pull old codes? Did they fix the buggy?
Rectangle Font Material property Screenshot Parallel
Rectangle Font Screenshot Parallel Operating system
 
1 - 8 of 8 Posts
Top