Can-Am Commander Forum banner

Normal key or performance

1298 Views 6 Replies 5 Participants Last post by  StevieNH
Im sure I have the performance key as I can go over 55, but i get no message on my gauges when I start up. Isnt it supposed to say something? Thx
1 - 7 of 7 Posts
Yes it should scroll on dash preformance key when you first turn key on.

Sent from my SM-S908U using Tapatalk
I wonder if they did away with that notification with the new models. I was perusing the '22 owner's manual, and it made no mention of it. It is mentioned in the older model manuals.
21 model still scrolls on the x3 don't know about the 22. They both run same system. And eco light is on when preformance switches off.

Sent from my SM-S908U using Tapatalk
Plus the x3 and the original maverick would idle at 1550 in preformance mode verses 1250/1350 in eco.

Sent from my SM-S908U using Tapatalk
My 21 Commander XT doesn't scroll. But, I only have the performance keys and haven't tried the others. And like Ace, mine does say Eco/Sport on the display at all times.

On a short side note, has anyone read a post about using Eco while rock crawling? I have tried it and it is a smoother, less jumpy throttle ride. But I end up leaving it in Sport just because
My 21 Commander XT doesn't scroll. But, I only have the performance keys and haven't tried the others. And like Ace, mine does say Eco/Sport on the display at all times.

On a short side note, has anyone read a post about using Eco while rock crawling? I have tried it and it is a smoother, less jumpy throttle ride. But I end up leaving it in Sport just because
Many trails here in the northeast are tight, steep rocky and twisty so I spend more time in Eco mode than Sport for the same reason. Throttle control is much more forgiving when precise navigation is needed and I'm being tossed around. I flip the switch to Sport when the trails open up, though...just because... :p
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top