Can-Am Commander Forum banner
121 - 140 of 189 Posts

·
Administrator
Joined
·
27,739 Posts
OK let's do a little better with getting along.
Would have been nice if the cardboard shaft would have helped someone. Being brp went through the trouble to make the shaft with cardboard in it. Guess maybe they should have followed GM's lead and put foam in them.

Sent from my SM-S908U using Tapatalk
 

·
Administrator
Joined
·
27,739 Posts
This is a old issue. It started with the x3. The solid carrier bearing from sandcraft and satv fix the problem on the x3. And all can am sxs use the same bearing from the factory. The shaft is to long for one rubber mounted carrier to stop the out of balance lope. You can get the shsft balance but it doesn't stop the chatter cause from the loping.

Sent from my SM-S908U using Tapatalk
 

·
Registered
Joined
·
11 Posts
Here is a link to a video with the noise we were talking about. Let me know if you can't access it and I'll share another way.


 

·
Administrator
Joined
·
27,739 Posts
At very beginning I could hear the drives shaft chatter but once you started accelerating that wasn't driveshaft anymore. That in the video I'm not there hearing it in person but that's in the gearbox from what I'm hearing. Could possibly be incorrect tolerance in the secondary clutch. If there's to much Clearance in the back half of the secondary it will wobble and make it sound like everything is coming apart. But that is typically a high mileage wear issue.

Sent from my SM-S908U using Tapatalk
 

·
Registered
Joined
·
25 Posts
Alien, I can’t view your video. Any chance you can host it somewhere else?

Prior to my third visit to the dealer, mine sounded like a jack hammer between 3800-4400, confirmed by the service manager who recorded a video of it. I got it back this week and once again the vibration was muted but still there. The driveshaft, front shaft and carrier bearing were all replaced this time.

Decided to take it to AOAA in Shamokin, PA yesterday for some fun - that is why I bought it, after all. Seemed like it started to come back but was hard to tell with a helmet on. Decided to take it for a spin up the driveway today after washing it and sure enough, it’s back. I guarantee it will get worse with every mile I put on it.

Can Am doesn’t seem overly enthusiastic about correcting this issue. I just want out of the machine at this point.
 

·
Registered
Joined
·
1 Posts
i have a 2022 sport max with 300+ miles and i have noticed this vibration sound between 3600-4600 rpm . it only happens in sport mode 2 wheel it does not happen in sport 4 wheel or in eco 2 or 4 wheel. it seems to be a tinny metal springy sound. is this what you are talking about?
 
121 - 140 of 189 Posts
Top