Can-Am Commander Forum banner

1 - 10 of 10 Posts

·
Registered
2012 Commander 800 XT
Joined
·
9 Posts
Discussion Starter #1
I've recently bought a 2012 Can Am Commander xt 800. It's needed a little TLC but it's getting there!
My latest issue is that I bought a new battery and it's not charging. I've tested the voltage at the battery, with the machine off, I'm getting 12.7 volts. With the motor running I'm getting 12.5/12.6 volts. I don't have any warnings on my dashboard so I don't know what to do next! Any ideas would be greatly appreciated!!! Could it be the voltage regulator or Stator or both. How do you check them?
 

·
Super Moderator
Joined
·
24,549 Posts
If battery is at 12.7 ish with it off it’s not going to charge at idle battery is already charged . Put you meter back on the battery and rev the rpm’s up to 5000 and see what it reads.
 

·
Registered
2012 Commander 800 XT
Joined
·
9 Posts
Discussion Starter #5
Well, that makes sense! I've only been riding it around the yard and not pushing it much. I didn't have any brakes until today! The Master Cylinder was bad and I put a new one on today. I need to bleed the brakes again, pedal is not perfect but at least I have some brakes now. I may need to change the pads as well to finish the brake system out!
So far I've replaced the front left axle, front left brake line, battery, drive belt spark plugs, fuel pump/pressure regulator, changed oil/filter, lower tailgate handle, right rear light, and the tilt wheel cylinder. I'm still going to change out both rear and front right axles and I think I will be about done for a while. Oh yea, I've got new seat covers too!!!. I got this machine for a super price so I've got some room to fix her up and still be way under resale value!!! Thanks again for the info and I will try tomorrow and report back!!!
 

·
Super Moderator
Joined
·
24,549 Posts
The brake pedal when working properly will still feel spongy but you hammer down in the pedal it will lock the wheels up at just about any speed. The rear line is so long it takes for ever to get the air out. Every time I think I’m done I pump it up one more time then here comes more air . But the pedal on a new machine feels horrible but they stop.
 

·
Registered
2012 Commander 800 XT
Joined
·
9 Posts
Discussion Starter #7
Back to the battery issue, I went for a short ride and the check engine/ low voltage warning. Could that be a bad voltage regulator, stator or both? How do I check each? Thanks in advance for all the advise, you guys rock!!!
 

·
Super Moderator
Joined
·
24,549 Posts
No problem it’s a 13 manual but only thing that changed from 12 to 13 was axle shaft size and the rack and outer tie rod joints . And secondary clutch spring .
 
1 - 10 of 10 Posts
Top