Can-Am Commander Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have searched for a while now. I am working on my neighbors machine, he brought it to me and said it wouldn't go over 45. I measured the belt and it was out of spec so I pulled the clutches and cleaned it all up and got a new belt and put it back together. Then I realized it was being governed at 45mph with rpms at about 6k. The black key is being used and Is the only key that had ever been used so what would cause it to govern like that?
 

·
Registered
Joined
·
1,184 Posts
Does the dash say 'performance key' when it's booting up? Does the dash show high gear?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
It doesn't say anything about the key. Is it possible it has reverted to a default setting or something like that? It is the only key he has for it that fits. The grey key is on the same ring and he said he has never used it. I figured I would try it but it won't even go in the ignition.
 

·
Registered
Joined
·
1,184 Posts
I wonder if the switch is poopy. With the performance key, it should say such on the cluster at boot-up. If it doesn't recognize the "p" key, speed is limited to 43 mph and 70% torque. Others here have cleaned the key with WD-4000, and maybe the ignition switch (not sure about the switch). Maybe some will chime in.
 

·
Registered
Joined
·
14 Posts
isn't the white key the performance key? black key is speed limited I think. Sounds like you were supposed to have 3 keys but you only got 1
 

·
Registered
Joined
·
1,184 Posts
The ECU is actually programmed to recognize a key as one of the three modes. So using PUDS, you could make your gray key the performance key. Commanders (don't know about the newer ones) come with 2 keys....black recognized as performance, and gray recognized as normal ( why is 43 mph top speed "normal"?:oops: ). An orange "work key" can be purchased and programmed separately.....I think that limits to 25 mph. The key colors are just for user identification.
 

·
Registered
Joined
·
1 Posts
I have searched for a while now. I am working on my neighbors machine, he brought it to me and said it wouldn't go over 45. I measured the belt and it was out of spec so I pulled the clutches and cleaned it all up and got a new belt and put it back together. Then I realized it was being governed at 45mph with rpms at about 6k. The black key is being used and Is the only key that had ever been used so what would cause it to govern like that?
The dealer can re-program both keys for Performance! Also seat belt on drivers side has a safety! Click it or bypass it!
 

·
Registered
Joined
·
23 Posts
I have searched for a while now. I am working on my neighbors machine, he brought it to me and said it wouldn't go over 45. I measured the belt and it was out of spec so I pulled the clutches and cleaned it all up and got a new belt and put it back together. Then I realized it was being governed at 45mph with rpms at about 6k. The black key is being used and Is the only key that had ever been used so what would cause it to govern like that?
Change the spark plugs. A member on here told me the same thing when mine did this and it was one plug dead. It never missed or cut out, just wouldn’t go over 45mph
 
1 - 8 of 8 Posts
Top