Can-Am Commander Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
Hey y’all. I’ve got a 2014 commander 800xt here it has an intermittent hesitation sometimes once the engine is up to temperature/hot. If I allow the bike to sit for a bit the problem goes away, before it seemed to only do it while cornering which lead me to believe maybe fuel was sloshing away from the fuel pump in the tank but the other day it also did it in a straight line on flat ground as well as when climbing a small hill. The check engine light came on for a bit so I stopped and did an ignition cycle, engine light stayed on for another few minutes and then cleared itself.
I’ve since tried cleaning the vss, new spark plugs, adjusted the valves, removed and thoroughly cleaned the radiator, checked the fuel tank vent by putting shop air down it and the tank pressurized then bled back off out the vent hose and cleaned the spark arrestor but problem persists.

I also tried throwing in 10L of fuel once the bike started acting up during a ride and it didn’t seem to help.

when I say hesitation it’s like the bike loses all power for 1-2 seconds and then comes right back like nothing happened.

anyone run into this before? Looking for Ideas on where to go next. I’m thinking about replacing the fuel pump?
 

·
Registered
Joined
·
1 Posts
I seem to have a similar issue. It feels like the spark is cutting out for me on my 2020 800r dps (only 200 miles). The problem first started about a month ago, spark would cut out when heavy on the throttle and would come back a second or two later. If I keep the gas pressed during this it will throw a check engine code and put me in limp mode. Problem has slowly gotten worst and happens on light throttle now too. Seem like it happens mostly when unit is fully warmed up. Check engine goes away after turning off and on and a short ride. Would love some help with this! I tried replacing the ignition coil and problem still persists.
 

·
Registered
Joined
·
12,897 Posts
My commander and mav both did the same thing and it was a fuel pump


Sent from my iPhone using Tapatalk
 
1 - 3 of 3 Posts
Top