Can-Am Commander Forum banner
1 - 12 of 12 Posts

·
Registered
2015 Can Am Commander 800R
Joined
·
40 Posts
Discussion Starter · #1 ·
2015 Looking for advice on troubleshooting gauge that reads empty always. From various threads it appears to often be the sending unit in the tank. Are there any good pictures of this pump/sending unit and ways to fix without replacing entire pump unit? I see a nicely priced pump rebuild kit but appears to have nothing for the fuel level.
 

·
Administrator
Joined
·
27,013 Posts
I would first pull the unit out get a ohm meter and test the float side. Make sure the float is actually dead electronically. Check the float itself you make sure it is floating and not full of gas. If it floats and the sender is working then you have a wiring issue somewhere between the plug at the pump and the gauge . The sender show snow ohm Metering just say 100 being in the full range and 0 being empty. It probably won't be 0 to 100 but it will read between two points and should with no dead spots. We have had far more issues with the floats no longer floating than the sending unit actually being bad.

Sent from my SM-G998U using Tapatalk
 

·
Registered
2015 Can Am Commander 800R
Joined
·
40 Posts
Discussion Starter · #3 ·
I would first pull the unit out get a ohm meter and test the float side. Make sure the float is actually dead electronically. Check the float itself you make sure it is floating and not full of gas. If it floats and the sender is working then you have a wiring issue somewhere between the plug at the pump and the gauge . The sender show snow ohm Metering just say 100 being in the full range and 0 being empty. It probably won't be 0 to 100 but it will read between two points and should with no dead spots. We have had far more issues with the floats no longer floating than the sending unit actually being bad.

Sent from my SM-G998U using Tapatalk
Was trying to get ahead of shot gunning the problem. So what is the the float made of? I have seen a porous material that gets saturated when the coating is breached to an actual small tank meant to hold air. Is the float repairable?
 

·
Administrator
Joined
·
27,013 Posts
You can find a float that will work from auto stores. The complete unit from can am is 350 plus. So that's why you find something that will work. I may have a good float with low miles but it's still 7 yrs old . So if you can't find one local let me know .

Sent from my SM-G998U using Tapatalk
 

·
Registered
Joined
·
1,314 Posts
Here's a little pertinent info. I can post electrical troubleshooting info tomorrow if you need.
 

·
Registered
2015 Can Am Commander 800R
Joined
·
40 Posts
Discussion Starter · #6 ·
You can find a float that will work from auto stores. The complete unit from can am is 350 plus. So that's why you find something that will work. I may have a good float with low miles but it's still 7 yrs old . So if you can't find one local let me know .

Sent from my SM-G998U using Tapatalk
I found this as a rebuild kit but it does not appear to include float.
All Balls Gas Petrol Fuel Tank Pump Repair Rebuild Kit
$ 69.26
 

·
Registered
2015 Can Am Commander 800R
Joined
·
40 Posts
Discussion Starter · #7 ·
Here's a little pertinent info. I can post electrical troubleshooting info tomorrow if you need.
definitely appears to be valuable. Thanks. The electrical info may save me from pulling the pump and creating an issue. Thankis again.
 

·
Administrator
Joined
·
27,013 Posts
Stay away from anything all balls. Imported Chinese junk. That thread that was linked has a float part number listed in it.

Sent from my SM-G998U using Tapatalk
 

·
Registered
Joined
·
1,314 Posts
Here's the electrical test for the sending unit. If you have to go to the input voltage test, plug the multifunction guage back in first. The manual fails to tell you that (input voltage comes from the guage).
Font Screenshot Electronic device Multimedia Web page

Jaw Organism Font Adaptation Screenshot
 

·
Administrator
Joined
·
27,013 Posts
All balls moose and quad boss all same parts same factory different box.

Sent from my SM-G998U using Tapatalk
 
1 - 12 of 12 Posts
Top