Can-Am Commander Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
Having fan problems. The fan doesn’t run. I can reach in and give the blades a little flick and it’ll kick on and run like normal. Checked fuses. Checked wiring. Greased connections with dielectric. Installed a fan over ride. Same thing. Turn the override switch on and it gets power but needs a little push. Is my fan shot and I need a new one or can I take it apart and clean it up maybe replace a bearing or two.
 

·
Registered
Joined
·
2,773 Posts
I think I’ve seen a couple posts where people have taken them apart and cleaned with luck. I think I saw a post by Troy where he found brushes that fit and replaced.
 

·
Registered
Joined
·
636 Posts
For the amount of work involved in changing the fan along with the cost of a new one I think you would be better off replacing it
 

·
Registered
Joined
·
1,205 Posts
I agree with Hammer. Cooling fan, water pump, fuel pump, etc. Do it right the first time, so they don't fail on you again at an inconvenient time and location.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #5 ·
Water pump is working. Replaced temp sensor and thermo. Has anyone had this problem before? I’ll probably order a new one soon.
 

·
Registered
Joined
·
1,205 Posts
You said that with a little physical help, the fan will operate. Unless you're getting low voltage, that would tell me that it's the fan. If you are getting low voltage, you could replace the fan relay (or do it anyway to rule it out).
 

·
Registered
Joined
·
2,773 Posts
Look at this thread and use the search function to find others. Troy talks about rebuilding the fan in it.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #8 ·
Hey guys thanks for the info. I’m gunna look into some more on the Hayden although it seems like it isn’t as hefty from what the people say. I’m also gunna check out the spal. Does anyone have experience with that “upgrade” fan they have? When I pull the OEM one out I wanna check a few things. One guy said he hit his with penetrating oil and it freed it up. Another said to make sure the vent isn’t clogged. Some others said the brushes are easily available at auto parts stores. Couple options and a lot of knowledge. Thank you guys for getting me to this step
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #9 ·
update ran to advanced auto. Picked up the Hayden. The numbers matching Hayden at advanced was slightly different. I’ll include in pictures. Swapped it in. Wired it up. Bam. Fan works now. Hayden is a little lighter. Took apart the can am motor and man was that thing rusty. I also swapped thermostats. Temp sensor. And now I’m working on burping all the air out. Just ordered that big ass funnel kit to make it easier.
 
1 - 9 of 9 Posts
Top