Can-Am Commander Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi folks,

I have a 2012 commander 1000xt

The steering rack was damaged so we had an ez steer rack and motor installed after reading favourable reviews.

It's all installed and working but check engine light is on saying "check dps"
Vehicle also won't go over 15mph and can hardly pull up a hill.

I spoke to ez steer, they told me as my vehicle came with power steering, that I would need to have can am clear the code and flash the ecu so that it doesn't look for the power steering.

I called can am and service center tells me that they can't change ecu to none power steering, that the code will exist as long as the connectors are not plugged into power steering unit. I asked him if the code would go away by itself if I connected the wires up, he told me maybe if I drove 4-5 miles, the computer would see the steering motor and code would go away.
He also told me that by the description it is in limp mode.

I decided to dismantle the old power steering pump and hook up the wires to the connectors and drive it around for a while, nothing happened, light still on and limping still.

I tried to clear the engine light by tying the positive and negative wires together, nothing changed.

I cannot get the exact code as my headlight switch isn't working.

So my question is, what is the point of installing an ez steer on a can am that already has power steering if it will cause check engine and limp mode?

How have other people installed ez steer and not gotten a check engine light?

Is there a way I can trick the ecu into 'seeing' a power steering motor?

Will clearing the code bring it out of limp mode?

Will it actually leave limp mode by itself if things are hooked up to the ecu's liking?

Many thanks for any ideas and input.

Daley
 

·
Registered
Joined
·
2,735 Posts
Your machine must be a 2013 or newer if it has dps.

Plenty of folks have replaced the dps with ezsteer. I don’t recall anyone mentioning limp mode. Turbo392 mentioned taking his to the dealer and having them disable dps through the buds computer but that was for an irritating message scrolling, not being stuck in limp mode, iirc. Your stealership doesn’t know what their talking about. My local one doesn’t either for lots of things. It’s common.

Two things: 1: take apart your headlight switch and clean it so it’ll work (or replace it if you can’t get it to work but you should be able to fix it) and you can retrieve your actual codes to make sure there’s not something else also at play (you said “had it installed” so the installer could have inadvertently unhooked something or you could have if you did it 2: message turbo392 and see what he says since he switched his out fairly recently.

Here’s turbos thread so you can look through it and message him: Good riddance DPS, here’s the autopsy.

BTW, I love my ezsteer.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Thanks a lot for your advice, I have written to turbo, hopefully he replies.

I will clean out the switch in the morning, never thought about that, but it makes sense, my ignition went the same way.

I am liking the ez steer, just not the 15mph!!
 

·
Registered
Joined
·
2,735 Posts
Hopefully turbo will get back to you. He is still around the forum I think.
Here’s a couple pics of the inside of the switch. You’ll see a carbon build up on the contacts that can be cleaned off. If you have some dielectric grease put on the contacts when done and the problem won’t recur as quickly.
Automotive tire Asphalt Floor Bumper Road surface
Bumper Wood Automotive tire Gas Automotive exterior
 

·
Vendor
Joined
·
376 Posts
I can't recall anyone ever complaining about the "check DPS" light before, but I suppose its the same as the more modern machines with DPS. The ECU is searching for the stock unit and can't find it, so it shows the code. That shouldn't put you in limp mode though. That has to be something else. I think @slowindown has it figured out. Following along...
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
Hey there,

I'm not complaining, just having an issue with my vehicle after install and trying to resolve it. I think the steering is great with the unit.

I have to imagine anyone that has installed this unit on a vehicle that has stock power steering already installed is going to have, or have had a similar issue. The ECU is obviously going to be looking for the DPS.

It might be worth talking about this issue in the page of your install manual that talks about installing EZ Steer into vehicles that already have power steering as it doesn't really say too much. I don't think just tying the original wiring out of the way is going to work.

Anyhow, I went into dealer today, they are going to turn off DPS on my ECU via BUDS, apparently it needs to be the older version of BUDS to do this, I don't know how true or false that is. Either way they want $120 for the privilege! I am taking it in tomorrow.

Thanks for the photos of the switch, I am off to clean mine now so I can see what/if there are any other codes stored.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #7 ·
I just got the light switch going again and pulled the code,

P0636.

Low voltage fault on dps.

I don't know for sure this is causing limp mode or not but it's the only code.
I will let you know what dealer finds out or how things are once dps is fixed in ECU.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #8 ·
So I got to the can am dealer and had the dps disabled on the ecu.

They told me there are no other codes and that it's not showing as being in limp mode.

I only have the work key available at the minute, I work for the owner of vehicle and he has the other keys.

It won't go up hills, over 15mph on a straight, or rev above 6k sitting still or 4k at 15mph on a straight.
Do these sound like normal figures for work key?

I used it many times to go into the woods up hill with the work key and I don't remember having problems.
Could the fuel filter be clogged? Any other obvious places to look or test?

Many thanks.
 
1 - 8 of 8 Posts
Top