Can-Am Commander Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
I posted a while back about my display acting up. Got it working and it died again so was going to order a XT cluster. I know dealer will have to flash it, but do they use the same mount? I've been looking at parts diagrams and can't tell.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #2
Update, I found the correct mount. Is there another cover or other parts needed to complete the swap?
 

·
Registered
Joined
·
23 Posts
Discussion Starter #7
Cool, I appreciate it. Looking forward to the swap. I've read some info on it, but they're mostly geared towards the electrical part. Couldn't find anything on mounting it.
 

·
Super Moderator
Joined
·
24,888 Posts
I have a cluster off a 800. But the mounts are different on the quad and with the xmr snorkel I haven’t figured out if it will fit yet.
 

·
Registered
2019 commander 1000r
Joined
·
15 Posts
So just the mount ring and there's no other trim or anything that goes around it?
I just did this swap on my 2019 commander ..dps to xt ...make sure you buy the correct year cluster ..
So just the mount ring and there's no other trim or anything that goes around it?
I just did this swap on a 2019 commander ..make sure you buy the correct year cluster ..and you need mounting bracket and cluster cover and the screws for the cover..mine did not need to be flashed everything works but is on kilometer instead of mph..hope this helps..by the way all mounting brackets and covers are the same.. only the clusters are different as far as year ...to the best of my knowledge
 

·
Registered
Joined
·
3 Posts
I posted a while back about my display acting up. Got it working and it died again so was going to order a XT cluster. I know dealer will have to flash it, but do they use the same mount? I've been looking at parts diagrams and can't tell.
Did you get the swap done.
What issues are you having with the stock cluster?
 

·
Registered
Joined
·
23 Posts
Discussion Starter #13
Hooked up and worked fine. Did have to have dealer change to mph. Does take a different mount, my original just quit. Wouldn't display anything.
 
1 - 17 of 17 Posts
Top