Can-Am Commander Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have a 2013 Can Am Commander XT 1000. It just sarted stalling, would not run at idle and now will not start. Battery good and starter is ok. It turn over but will not start now.
 

·
Administrator
Joined
·
27,013 Posts
Check Fuel pressure . You can get a test kit from auto part store.

Sent from my SM-G998U using Tapatalk
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Got new plugs to try. Dont think I gota check engine light. Was running rough at idle and would stall. It would restart ok but needed to stay into a little throttle to keep it from stalling. Did this for 10 min.
Would run ok but stall at idle. Notice a few low quiet back fires. Now wont start at all. Turns over strong.

What should the flue pressure read at?
If its low - what then?
 

·
Administrator
Joined
·
27,013 Posts
50+ at all times. Fuel pump and plugs will not turn the light on that's why I asked.

Sent from my SM-G998U using Tapatalk
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
So - if check engine light is off it could be plugs or pump?
Its 9 yrs old. Has ran great with very few miles on it. Only use it to snow plowetc. around my 3 acres.
Now it wont start at all.
 

·
Administrator
Joined
·
27,013 Posts
I would say it's the pump. It will run fine with one dead plug. But you may have been running on one then the other died .

Sent from my SM-G998U using Tapatalk
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
Ok. Will try plugs first.
Is the fuel pump change a difficult job?
Anything else it's likely to be?

Thanks
 

·
Administrator
Joined
·
27,013 Posts
Not hard job. But would definitely check pressure before changing it. You can get new pump from auto part store. Whatever you do do not buy a quantum pump they are junk .


Sent from my SM-G998U using Tapatalk
 
1 - 9 of 9 Posts
Top