Can-Am Commander Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Commander wont go fully in reverse half the time. Jus grinds then goes in after a couple sec. and when going down the road. Around 90 km. Feels like its trying to jump out of gear for a sec. then fine for another min then does it again.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #2
Also. I think the reverse thing only started when i put a new belt on. I already adjusted the linkage. And took the belt cover off and looked to see if the belt was spinning at idol. It was not. But the other day when i was putting the new belt on i thaught i seen the belt creep ahead jus a little. Jus wondering if gear box is shot. Or anything i can do
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
1 more thing my bike did since i bought it 6 months ago. If im spinning on ice or snow. It will kinda cut out a couple times on higher rev. Before getting full power. If that makes any cents
 

·
Super Moderator
Joined
·
25,678 Posts
Sounds like you got something going on with the reverse gear internally. As for the cutting out on snow and ice that's the shaft saver. It's programmed into the ecm to detect excessive wheel spin and pull the throttle out to stop the spinning.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Sounds like you got something going on with the reverse gear internally. As for the cutting out on snow and ice that's the shaft saver. It's programmed into the ecm to detect excessive wheel spin and pull the throttle out to stop the spinning.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
I did not no about the shaft saver. Was hoping for some more options. Before putting in a new gear box. Thanks for the info!
 

·
Super Moderator
Joined
·
25,678 Posts
If it's just reverse giving you fits it could just be a worn gear or bearing. If you do decide to buy a new box. Do not buy one from mrrpm they are junk and he doesn't stand behind them even with less than 50 miles if they let go. Slowingdown has a very detail thread on the gearbox.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8
Ok. On high speeds 90km or so it gives the odd jerk every few mins. So im not sure if thats kinda jumping out of gear or i got a other problem. Thanks for the info!
 

·
Super Moderator
Joined
·
25,678 Posts
Yeah hard to say not being there. But typically if it's a clutch issue you will have same issues in more than one gear. But you may have multiple issues.
 
1 - 11 of 11 Posts
Top