Can-Am Commander Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter #1
Just opened up my clutch after getting it back from UATV Tech. I noticed that one of the spaces where the governor cup assembly fits into the other half is slightly bent, making it tight to get in. Is this going to affect smoothe/proper operation? Can I remove material or try to bend it back slightly? Any suggestions?
 

·
Super Moderator
Joined
·
23,013 Posts
If it’s slight mate it up correctly and tighten it down then remove the gov cup to see if it straightened out and it made contact with the gov cup.
 

·
Registered
Joined
·
76 Posts
Discussion Starter #3
How far should it freely move apart once they're together? I've got them together but need to know it's not prematurely bound. It will go all the way in, just not back out all the way.
 

·
Super Moderator
Joined
·
23,013 Posts
Put the inner on then put it all together . Take it back off and look at the shaft where the ding is and look at the cone on the gov cup. If it goes together and straightens out or it doesn’t hit the governor cup when tight . Run it it should be fine .
 

·
Registered
Joined
·
76 Posts
Discussion Starter #8
It's not the shaft. It's where the rollers go up and down when the weights go out. The channel that the roller slides up and down in is tight at the top half.
 

·
Registered
Joined
·
3,168 Posts
I'm confused but will ask for clarity, are you talking the buttons maybe? they don't roll but are round bout the size of a nickel
 

·
Registered
Joined
·
12,542 Posts
I think one of the posts are bent from shipping and it’s now binding on one set of buttons


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
264 Posts
I've had this happen before. place the sheave with the bent slide and place it in a vice long way of the slider and easily tweak it back out a smidge, then recheck to see if the governor cup will slide. These get bent quite easily with peope using bars, screwdrivers or placing 2x4 against them to hold clutch for loosening and tightening.
 

·
Registered
Joined
·
76 Posts
Discussion Starter #13
Got it all put in and took it for a test ride after running it in the garage. It seems fine. I haven't tried to hit top speed, but I think I hit 60 or so, and no problems. I did not attempt to bend it back, should I? Under normal operation, how far apart do the sheaves go back and forth, or in and out?
 
1 - 14 of 14 Posts
Top