Can-Am Commander Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
help please for the last week when i stop and let my commander idle either in gear or park it will throw the check engine light on then after 15 seconds or so the engine will surge down once and throw the limp home mode on. if i shut it off then restart it and drive it runs fine and clears the light until i stop and let it idle again i have checked the code and its po 302 which is miss fire detected but it only ever miss fires when it goes into limp mode i read it does that when the ecm detects something it shuts down one injector which causes the miss fire but i cant seem to figure out what is causing the check engine light at idle i have checked the plugs, air filter, fuel pump, belt, oil, coolant, battery and electrical conections around the motor i am STUMPED please i hope someone can help!!!
 

·
Super Moderator
Joined
·
25,662 Posts
Only way to get miss fire code is if crank position sensor is bad or dirty. To my knowledge the Ecm doesn't read coil out put or plugs. And I know for sure that plugs can be dead not firing and ecm will not code. So I would start with crank sensor on right front of motor.
 

·
Super Moderator
Joined
·
25,662 Posts
Welcome enjoy all the info you can. At some point booger will disappoint you with his comments. We just ignore him and let him play his games. Sometimes he does get lucky and make a funny!!!
 

·
Super Moderator
Joined
·
25,662 Posts
Mass air has its own code. I would say it tells you in the manual how to test the crank sensor with a meter.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #10
i dont have a manual would you happen to know the test procedure on the other hand its probably worth the money to go out and buy one
thanks
 

·
Registered
Joined
·
8 Posts
Discussion Starter #12
thanks for the manual and the help but still stumped i just spent the day going over everything again, tested the cps and mafs both tested good changed the oil and greased it and put it back together very aggravated at this point i dont really want to send it to the dealer but probably going to have to i dont want it to quit on me i literaly drive it every day over 2000 miles just in the last two and a half months
 
1 - 12 of 12 Posts
Top