Can-Am Commander Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hey everyone. I have a 2011 commander 1000xt. Warning light comes on and says brake on dash, brake lights don’t work and it cuts power ever now and again. I replaced the switch on master cylinder and it helped for a little bit still does it time to time. Any suggestions on what to look at?
Thanks
 

·
Administrator
Joined
·
27,410 Posts
Check the wires on frame and on bed. If you have a short it could be causing the fault. Also the sensor could be bad. Have seen brand new out of the box that were bad.

Sent from my SM-S908U using Tapatalk
 

·
Administrator
Joined
·
27,410 Posts
Also make sure your master Cylinder isn't sticking . When it says brake on dash it think you are pushing brake and giving it gas at sane time.

Sent from my SM-S908U using Tapatalk
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Also make sure your master Cylinder isn't sticking . When it says brake on dash it think you are pushing brake and giving it gas at sane time.

Sent from my SM-S908U using Tapatalk
Everything checked out good. I have a blinker kit installed that plugs right into rear light harness and I unplugged that and the problem went away. Plugged it back in and problem came back so not sure what is going on with that kit but I found the source of the problem.
 

·
Administrator
Joined
·
27,410 Posts
I would guess you getting power from the park lights bleeding over into the brake side of the harness. Shorting out causing it to be intermittent. I would pull the loom off the turn single kit and look for bad wire. And if it's only doing it when you got the blinker not sure what to tell ya. But regardless it should be able to baxk feed through the pressure switch .

Sent from my SM-S908U using Tapatalk
 
1 - 5 of 5 Posts
Top