Can-Am Commander Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
My commanders check engine light just came on and stayed on. Also I all of a sudden have no headlights. Nothing else seems to be wrong. No loss of power. Any advice? Thank u
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
The check engine only comes on after I start the engine. For some reason I can not get into the fault code mode. Also the fuses look fine. Also what’s the
65644
difference between the mode button and selector button?
65643
65642
 

·
Super Moderator
Joined
·
25,989 Posts
Replace the fuse and switch the relay out with one of the others . To see if the light problem moves.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #10
So from everything I’m reading, the check engine that I’m having is possibly from a fuse or relay and it only makes the engine light come on when the engine is running and I can’t pull the code because that can only be done when the engine is not running. Which the engine light never is on when it is not started and running. The can am is only 1 year old and only run on the ranch with kids. Not worked hard at all. I took it to the Oregon dunes once last December. I change the filters and oil regularly. Thank u all.
 

·
Super Moderator
Joined
·
25,989 Posts
Yeah dealer is the only one that can pull inactive codes. If light comes on at any time a code is stored. But if light goes out when key is off the problem has fixed it’s self until you start it back up then light comes back on . We can only pull active codes. That’s a problem that is read with it on or running . And once you fix the problem the light will go off without and help from a computer.
 
1 - 11 of 11 Posts
Top