Can-Am Commander Forum banner

1 - 20 of 27 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I am not familiar with this vehicle. My father passed away and the commander hasnt been fueled or ran in 5 years. I put a new battery in it and it trys to crank, i am sure it is the old fuel. I am very mechanically inclined but not familiar with this vehicle. Any advice is welcome.
 

·
Registered
Joined
·
981 Posts
Yeah, 5 year old fuel is more than old. I would get all of that out of the tank, then put fresh in. Can you hear the fuel pump running when you turn the ignition on and the ECM is booting up?
 

·
Registered
Joined
·
86 Posts
If you plan to start using the Commander, you should have the steering stem connector looked at. There was a warranty replacment for them, as I recall. It is a safety issue !!
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
I will thanks!

What is the best way to drain it? Do i have to drop the tank? Sorry trying to make this as painless as possible.
 

·
Registered
Joined
·
2,607 Posts
The tank is not hard to take off. Theres a nut or bolt at the front and one at the back of it. Theres a few fasteners securing the plastic panel where the gas cap is and an electrical connector and fuel line. You probably want to take the fuel pump out and make sure the tank isn't rusted too - mine set up a long time before I bought it and I had to replace the tank because it had rusted. Fortunately I found a good used one.

Otherwise, you could just siphon it out.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
Took most of the plastic out. Yes the tank does show sign of plenty of surface rust. I can only guess the inside looks similar or worse. Also found were a little a rat or something made himself a home around the engine...awesome.
 

·
Registered
Joined
·
2,607 Posts
There's going to be surface rust. But the inside won't be rusted unless it got water in it through condensation or some other way. Mine got water in it somehow and sat that way for a while.

Look for chewed wires.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
Got it all cleaned out, wires seem to be good. I have spark on the plug, but not great, getting new plug tomorrow. I put in new fuel with cleaner. Sounds like a fuel pump is running. Any extra advice is very welcome! Thanks for helping a noob! My knowledge is limited but if you ever need help building a manned submersible let me know!
 

·
Registered
Joined
·
11 Posts
Got it all cleaned out, wires seem to be good. I have spark on the plug, but not great, getting new plug tomorrow. I put in new fuel with cleaner. Sounds like a fuel pump is running. Any extra advice is very welcome! Thanks for helping a noob! My knowledge is limited but if you ever need help building a manned submersible let me know!
Did you get it running Cinoble4?
My only concern is if you pumped some of that 5 year old gas into the fuel pump canister before you flushed the tank with fresh. I made that mistake with a bad load of gas and I could never get it all out of the fuel pump and had to replace it. Changing the white sock didn‘t help. Had to buy the whole thing for $459. Or something like that. but now she runs like a raped ape. :)
Keep us posted buddy!
 

·
Registered
Joined
·
11 Posts
Looks like the fuel pump isnt running. Fuse is good. On to the pump it is!
If you don’t hear it when you turn the key on before you turn key to start mode, probably not getting connection or something else.
I always like to disconnect the red battery cable before taking the fuel pump out. You don’t want a spark over the gas tank.
 

·
Registered
Joined
·
1,015 Posts
If you plan to start using the Commander, you should have the steering stem connector looked at. There was a warranty replacment for them, as I recall. It is a safety issue !!
Only on units that had power steering .
 

·
Super Moderator
Joined
·
25,807 Posts
No there was a recall on 11/12 manual steering as well. But it was back in 2013. 13 recall didn't happen till 2016. The 11/12 recall was from shaft being to short.
 

·
Registered
Joined
·
1,015 Posts
No there was a recall on 11/12 manual steering as well. But it was back in 2013. 13 recall didn't happen till 2016. The 11/12 recall was from shaft being to short.
Well I was told from my dealer and thru a factory memo that my 2013 was not effected (manual steering ) and with that thought in mind I still own the machine and had it at the dealer this past spring getting a few minor things done on it and to tell you the truth I just might have that memo yet.
 

·
Super Moderator
Joined
·
25,807 Posts
Manual steering on the 11/12 was recall and 13 dps coupler was recall. So if yours is 13 manual was already fixed when they hit the floor in August.
 
1 - 20 of 27 Posts
Top