Can-Am Commander Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hey new guy here. Bought a 2011 commander a few weeks ago. Seems to me that it is stuck in low gear even when the shifter is in high. Still can put in reverse and park. When in neutral sounds like it is trying to slip into gear when revved up. Tried moving the shifter in between neutral and high. Also between low and high with no results. So I'm thinking it is not the linkage that needs to be adjusted. Any ideas???? Ohh and the reason I think it is stuck in low is bc the rpms redline at 40mph.
 

·
Registered
Joined
·
135 Posts
Yeah, top speed in low is 40 mph. try shifting it with the engine off and rocking the machine. The dash should show what gear your in depending on the model.You must be starting it with your foot on the brake if its stuck in gear.
 

·
Registered
Joined
·
12,913 Posts
Sounds like it's the shift forks in the tranny
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
Definitely have the right key. Even says it on my dash when I start it up. I have tried putting it into high every way possible. It will sit in high and the dash will say high but either it will start grinding when I start giving it gas or it will only go 40 which would be low gear. Working on taking the gearbox off now to take a look inside. Really don't feel like spending 1500 to buy a brand new one so hopefully I can just rebuild it.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top