Brake error code on dash - Can-Am Commander Forum
 2Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 09-07-2019, 10:01 AM Thread Starter
Junior Member
 
Join Date: Jan 2019
Location: Chapmanville, WV
Posts: 20
Brake error code on dash

So today I am getting a brake error code and reduced power. I recently just put new ball joints bearings and front brake pads on this machine. Something I also done was put LED bulbs in my headlights. I read about checking for codes and it shows no active codes. 2013 can am commander X 1000. Where do I start looking?

Also it will start in gear with foot on brake. Also have led taillights. Thanks
wvbuckmaster is online now  
Sponsored Links
Advertisement
 
post #2 of 11 Old 09-07-2019, 10:46 AM
Senior Member
 
cannedham's Avatar
 
Join Date: Sep 2012
Location: Tennessee
Posts: 368
A faulty brake light switch, maybe failed in closed position, can cause this. Will it start in gear without brake pedal pushed?
acefire likes this.

If you love something, set it free. If it doesn't come back, hunt it down and kill it.
cannedham is offline  
post #3 of 11 Old 09-07-2019, 01:57 PM
Super Moderator
 
acefire's Avatar
 
Join Date: Aug 2012
Location: Charleston WV
Posts: 22,667
Brake error code on dash

When it codes take your foot and left up on brake pedal . Also check your brake lights make sure they are both working and not on all the time . Typically brake code is do to ecm thinking you are on throttle and on brake at same time. So if brake lights are working properly stop driving with two feet. Lol
acefire is offline  
Sponsored Links
Advertisement
 
post #4 of 11 Old 09-07-2019, 03:15 PM Thread Starter
Junior Member
 
Join Date: Jan 2019
Location: Chapmanville, WV
Posts: 20
so here is what is weird about the brake lights. i purchased after market brake lights last year. didnt know it for a while afterwards my brake lights do not light up when i hit the brake. the tailights are the only thing that comes on when i am running with lights.
wvbuckmaster is online now  
post #5 of 11 Old 09-07-2019, 03:36 PM Thread Starter
Junior Member
 
Join Date: Jan 2019
Location: Chapmanville, WV
Posts: 20
Quote:
Originally Posted by cannedham View Post
A faulty brake light switch, maybe failed in closed position, can cause this. Will it start in gear without brake pedal pushed?
yes it will start in gear without having foot on brake
wvbuckmaster is online now  
post #6 of 11 Old 09-07-2019, 03:46 PM
Senior Member
 
cannedham's Avatar
 
Join Date: Sep 2012
Location: Tennessee
Posts: 368
Well, that's where to start. I would think you could unhook brake light switch (at master cylinder) and see what happens.

If you love something, set it free. If it doesn't come back, hunt it down and kill it.
cannedham is offline  
post #7 of 11 Old 09-10-2019, 06:47 PM Thread Starter
Junior Member
 
Join Date: Jan 2019
Location: Chapmanville, WV
Posts: 20
finally got around to unhooking the sensor. engine will not start in gear. rode around some after that. light and brake message is gone and it runs fine with no limp more.

so i guess i need to replace the sensor, but will it matter if i still use it until i can do that?

thanks guys for the help!
wvbuckmaster is online now  
post #8 of 11 Old 09-10-2019, 07:37 PM
Super Moderator
 
acefire's Avatar
 
Join Date: Aug 2012
Location: Charleston WV
Posts: 22,667
My brake lights havenít worked for 3000 miles. Just drive faster than everyone else and they wonít be close enough to hit you when you brake hard to stop.
acefire is offline  
post #9 of 11 Old 09-10-2019, 07:39 PM
Super Moderator
 
acefire's Avatar
 
Join Date: Aug 2012
Location: Charleston WV
Posts: 22,667
Now hook the switch back up and disconnect the after market brake lights . I would guess they may be the issue if brake lights arenít working but will switch hooked up it will start in gear.
acefire is offline  
post #10 of 11 Old Yesterday, 09:01 PM
Junior Member
 
Join Date: Sep 2019
Posts: 1
So I get the brake error on the dash and goes in lump mode. Replaced brake switch still doing it. Well start in gear if I push on brake. Brake light are on all the time. Even if I unplug the pressure switch What can be the problem thanks for ideas
Chief al is online now  
Reply

  Lower Navigation
Go Back   Can-Am Commander Forum > Can-Am Commander General Discussion > Commander General Discussion

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
UTVinc.com Commander Parking Brake Kit Johnny UTV Inc 170 09-10-2019 12:56 PM
Brake light switch Sailorman3 Commander General Discussion 9 11-21-2018 05:19 PM
Trigger Brake lights sooner Fuggawi Commander Lighting, Stereo and Electrical 6 05-13-2018 01:18 PM
Brake fault help Stevo Commander Lighting, Stereo and Electrical 13 04-08-2017 09:51 AM
Gator 590 parking brake. (Untrustworthy IMO) Tnsharpshooter Other Side by Side Vehicles 2 12-19-2016 08:46 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome