1000 x problems... fan fuse, transmission

This is a discussion on 1000 x problems... fan fuse, transmission within the Commander General Discussion forums, part of the Can-Am Commander General Discussion category; hey guys i have a few problems/concerns and questions... i have a 2011 1000 x and i have had issues since its been new with ...

Go Back   Can-Am Commander Forum > Can-Am Commander General Discussion > Commander General Discussion

Reply
 
LinkBack Thread Tools Display Modes
Old 07-23-2012, 03:38 PM   #1
Junior Member
 
Join Date: May 2012
Location: sourthern illinois
Member #5169
Posts: 2
View Kyle_S's Photo Gallery()
1000 x problems... fan fuse, transmission

hey guys i have a few problems/concerns and questions... i have a 2011 1000 x and i have had issues since its been new with the fan fuse blowing after ive been in water.. the dealership replaced the fan motor assembly and it still had the same problem until recently the dealership put in a relay to trip instead of the fuse blowing. it seems to be working and not blowing the fuse but i was riding yesterday (in the midwest) and i ran about a five mile stretch down a road at about 60mph and it went into limp home mode due to over heating i slowed down and the fan was running... it cooled down and i continued on my way.. when i got home i smelled gear oil... i opened the dump bed and a breather hose by the cvt exhaust was boiling out gear oil onto the the exhaust and skid plate/ frame... any suggestions as to where i need to start... Can am corporate has already denied my claims on the fan stating that it was user abuse due to deep water going into a breather hose on top of the fan.. thanks
Kyle_S is offline   Reply With Quote
Remove Ads
Old 07-23-2012, 08:30 PM   #2
Senior Member
 
Capt.D's Avatar
 
Join Date: Apr 2009
Location: Atmore, Alabama
Member #31
Posts: 1,000
View Capt.D's Photo Gallery()
Was it the differential hose or gear box

Sent from my DROID RAZR using Tapatalk 2
Capt.D is offline   Reply With Quote
Old 07-23-2012, 09:18 PM   #3
Junior Member
 
Join Date: May 2012
Location: sourthern illinois
Member #5169
Posts: 2
View Kyle_S's Photo Gallery()
i would say it was the gearbox since it was that far forward... i'm guessing its the same issue i had with my renegade in that the gearbox takes in water through a shitty one way valve that's on the end of the hose and the water breaks down the oil and causes the excess to over flow.. my renegade was so bad when it was winter it would freeze in gear and i'd ave to drag it into my garage to defrost it in order to shift the gears when it was cold.. i fixed it by swapping oil and running the breather and valve over the handle bars
Kyle_S is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Can-Am Commander Forum > Can-Am Commander General Discussion > Commander General Discussion


Search tags for this page

can am commander transmission problems

,

can am commander problems

,

location of fan fuse on renegade

,

can-am fan noy working

,

can am commander x problems

,

can am commander fan fuse

,
can am x problems
,
commander 1000 xt trouble transmission
,
2012 can am commander transmission recall
,
can am maverick, smell gear oil
,
maverick x transmission problems
,
can am renegade 1000 transmission problems
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission Problems! Upgrades? flyingcrodeo Commander Performance Modifications 14 03-25-2012 11:28 PM
Transmission Problems!! Upgrades?? flyingcrodeo Commander General Discussion 0 03-23-2012 09:35 PM
Transmission Problems????? firedog83 Commander General Discussion 22 12-05-2011 11:59 AM
any problems with 800 or 1000???? clementransport Commander General Discussion 1 11-03-2011 01:25 AM
Fuse Block roaddog Commander General Discussion 6 10-09-2011 09:56 PM


All times are GMT -5. The time now is 03:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.