2012 Commander X Submerged in river...Help..

This is a discussion on 2012 Commander X Submerged in river...Help.. within the Commander 1000 forums, part of the Can-Am Commander General Discussion category; So i borrow my 2 month old commander to my brother and he ends up crossing a shallow river and on the way back hits ...

Go Back   Can-Am Commander Forum > Can-Am Commander General Discussion > Commander 1000

Reply
 
LinkBack Thread Tools Display Modes
Old 06-06-2012, 07:21 PM   #1
Junior Member
 
Join Date: Jun 2012
Location: Canada
Member #5270
Posts: 2
View Deliata's Photo Gallery()
2012 Commander X Submerged in river...Help..

So i borrow my 2 month old commander to my brother and he ends up crossing a shallow river and on the way back hits rock and its all down hill from there... he and his friend bail and it takes about 16 hours to find it and tow it out of approximately 12-15 feet of water...

Drained Diffs, drained oil and flushed multiple times, replaced air filter drained and replaced fuel. checked battery and is showing 13 volts everything seems good except one problem. When i turn key i can not hear fuel pump kicking in and the dash does not light up, a few seconds later the engine turns over and fires up, once the key is released from the start position the engine stops and everything turns off.

Has anyone experienced this? I really dont want to take to dealer and void my extended warranty yet so any help would be greatly appreciated, thanks!
Deliata is offline   Reply With Quote
Remove Ads
Old 06-06-2012, 08:46 PM   #2
Senior Member
 
Jriggs's Avatar
 
Join Date: Jan 2012
Location: Fort worth texas
Member #4131
Posts: 401
View Jriggs's Photo Gallery()
I'm sure your brother has money for a new one!
__________________
2012 Commander 1000 XT Magnesium
14" STI HD2
Utv Mountain Rear cage and seat
Can Am multimount winch kit
Half windshield
2014 Outlander 800r Max
Jriggs is offline   Reply With Quote
Old 06-06-2012, 08:52 PM   #3
Senior Member
 
teeroy's Avatar
 
Join Date: May 2010
Location: alberta
Member #259
Posts: 540
View teeroy's Photo Gallery()
go through every electrical connection, find every plug and separate them, blow the moisture out with compressed air and apply a liberal amount of dilectric grease and reconnect. if that doesn't work I think your dealer would be your only option. or start swapping parts with another unit
teeroy is offline   Reply With Quote
Old 06-06-2012, 10:19 PM   #4
Senior Member
 
hardup12001's Avatar
 
Join Date: May 2011
Location: Maumelle, Arkansas
Member #2523
Posts: 750
View hardup12001's Photo Gallery()
Sounds like you're screwed. You got insurance?
hardup12001 is offline   Reply With Quote
Old 06-06-2012, 10:21 PM   #5
LBR
Senior Member
 
LBR's Avatar
 
Join Date: May 2010
Location: Oregon
Member #234
Posts: 643
View LBR's Photo Gallery()
I'd suspect the ignition switch itself or the ignition switch /key DESS system unable to read the key due to moisture

sent from my twin-turboed Razr
__________________
LBR is offline   Reply With Quote
Old 06-06-2012, 10:34 PM   #6
Senior Member
 
james_commander_ltd's Avatar
 
Join Date: Apr 2012
Location: Spring TX
Member #4858
Posts: 242
View james_commander_ltd's Photo Gallery()
Well it will attempt to start, if the key jacked up it will not turn over. Might be engine or something
__________________
2012 Can-Am Commander Limited Blue

29.5 Laws
SLC lift kit
Custom radio w/ 4 x 8" Bazooka Tubbies
Punch 400
LED's
Warn front bumper, BRP rear bumper
Snorkels
james_commander_ltd is offline   Reply With Quote
Old 06-07-2012, 08:09 AM   #7
Senior Member
 
Mud Yapster's Avatar
 
Join Date: May 2011
Location: East Texas
Member #2464
Posts: 4,481
View Mud Yapster's Photo Gallery()
I'd do like Teeroy says and also remove your fuse cover and blow it out (dry it all out) and put die-electric grease on each fuse also. unplug the connection on the back of the key switch and blow it out also along with all other connectors like Teeroy says. You better change all fluids a bunch of times after you get it running also. Did you find any fish in the glove box? LOL
Oh don't forget to remove the vent hose from you radiator fan motor and try to blow the water out of the fan motor. Then squirt WD-40 up in there it will also help get the moisture out of it.
__________________
Commander XT1000

Mud Mafia
You hit this we hit you!!!!

Last edited by Mud Yapster; 06-07-2012 at 08:11 AM.
Mud Yapster is online now   Reply With Quote
Old 06-07-2012, 08:21 AM   #8
Senior Member
 
Buggy's Avatar
 
Join Date: Aug 2011
Location: Melfort Sask.
Member #3071
Posts: 136
View Buggy's Photo Gallery()
Check all your fuses for sure. I think there are two big ones outside the main fuse box.
__________________
2012 Commander 1000 XT
Buggy is offline   Reply With Quote
Old 06-07-2012, 08:32 AM   #9
Senior Member
 
Robmc80's Avatar
 
Join Date: Jan 2011
Location: Brighton CO
Member #1691
Posts: 531
View Robmc80's Photo Gallery()
My key has no start position to release from just the start button? There is some stuff called seafoam you should add as well, did they leave it running when they bailed out? Sounds like an insurrance claim either way.
Robmc80 is offline   Reply With Quote
Old 06-07-2012, 08:34 AM   #10
Senior Member
 
commanderman's Avatar
 
Join Date: Mar 2011
Location: Logan, UT
Member #2030
Posts: 509
View commanderman's Photo Gallery()
Insurance? Hopefully you do cause that machine will never be the same. Was the motor running when it went under?
commanderman is offline   Reply With Quote
Reply

Lower Navigation
Go Back   Can-Am Commander Forum > Can-Am Commander General Discussion > Commander 1000


Search tags for this page

can am commander submerged

,

submerged can-am commander 1000

,

video can am submerged

,

can am commander not going after being submerged

,

steps to take after submerging my polaris ranger

,

can am submerged

,
can am commander sumurged
,
submerged can am
,
success on can am commander submerged
,
commander xt submerged
,
running polaris ranger submerged in water
,
can am commander insurance claim
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mudding at River Run Mud Yapster Commander General Discussion 15 06-07-2012 08:27 PM
River Run Ride 1-28-2012 Mud Yapster Local Rides and Events 1 01-27-2012 03:36 PM
Anyone going to River Run Mud Holic event??? Mud Yapster Commander General Discussion 17 11-21-2011 11:19 PM
White River, Utah Burtonair01 Local Rides and Events 9 08-05-2011 04:53 PM
Mud Track Racing at River run. TexasDawg The Pits 1 04-12-2011 07:39 PM


All times are GMT -5. The time now is 01:03 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.